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Remediation Flow in PDF Documents 
If you have access to the source document 

1. Optimize the original source document for 
accessibility. 

2. Convert the source document to tagged PDF. 
3. Add metadata. 
4. Add or touch up the tags. 
5. Fine tune the reading order and tab order. 
6. Check the accessibility of your efforts. 

If you must start with a poorly tagged PDF 
1. Add metadata. 
2. Add or touch up the tags. 
3. Fine tune the reading order and tab order. 
4. Check the accessibility of your efforts. 

If you must start with an untagged PDF 
1. Add metadata. 
2. If the document is very simple, you can 

autogenerate tags in Acrobat Pro. 
3. Otherwise, create the tags manually. 
4. Touch up the tags. 
5. Fine tune the reading order and tab order. 
6. Check the accessibility of your efforts. 

If you must start with a paper or scanned 
document 

1. If necessary, scan the document. 
2. Apply optical character recognition (OCR) to 

create searchable text. 
3. Follow the steps above for starting with an 

untagged PDF. 

Before Converting to Tagged PDF 
Real, Semantic Elements (in MS Word) 

1. Headings should be real headings (not just 
big, bold text). In the Ribbon, go to Home > 
Styles group > select Heading style. 

2. Lists should be real lists (not just items with an 
asterisk). In the Ribbon, go to Home > 
Paragraph group > select list style. 

 

3. Real table of contents based on heading 
structure should be created. In the Ribbon, go 
to References > Table of Contents > select style 
of table. 

4. Real footnotes and endnotes should be 
created using the Insertion tool. In the Ribbon, 
go to References > Insert Footnote or Insert 
Endnote. 

5. Real columns should be created, rather than 
using the tab key. In the Ribbon, go to Layout > 
Columns > choose number of columns. 

6. Tables should be real tables. In the Ribbon, go 
to Insert > Table > select the number of 
rows/columns needed. Do not use the Draw 
Table option (it creates accessibility barriers). 

Headings 
• Headings should be real, semantic headings. 
• Headings should start at level 1. 
• Headings should not skip any levels. 
• Headings should provide a good, logical outline 

of the document's hierarchy. 
• Headings should be accurate, informative, and 

concise. 

Text 
• Fonts should be easily readable (standard fonts 

like Times New Roman and Arial are good 
choices). 

• Line spacing should be at least 1.5 within 
paragraphs. 

• Paragraph spacing should be at least 1.5 times 
larger than the line spacing. 

• Text should not be fully justified (fully justified 
text contains "rivers of white" space and is 
harder to read). 

Alternate Text 
• All meaningful images, graphs & charts, and 

other non-text content must have alt text. (Right 
click the image > Edit Alt Text > type in the 
description.) 

• The alt text must be meaningful (accurately 
conveys the purpose of the image, graph, etc.) 
and complete.  



 Quick Reference Guide: Basic PDF Accessibility 

 

Page 2 of 6 Copyright 2024 Deque Systems, Inc. All rights reserved.  Version 2024.08.05 

Before Converting to Tagged PDF 
(continued) 
Alternate Text (continued) 
• The alt text should be concise. 
• All meaningful non-text content must have a 

long description when needed. 

Color Contrast 
Text, buttons, icons that convey information, graph 
and chart components, form field text boxes, and 
other elements must meet minimum contrast ratio 
requirements. Exceptions include flags, 
photography, heatmaps, and other situations where 
changing the colors changes the meaning. 

Color Contrast Guidelines: 
• Small Text against the background: 4.5 to 1 min 

ratio with the background (small text is under 18 
point regular or 14 point bold). 

• Large Text against the background: 3 to 1 min 
ratio with the background (large text is at least 
18 point regular or 14 point bold). 

• User Interface Components and Graphical 
Objects: 3 to 1 min ratio against adjacent colors 

Links 
• Links must be correctly designated (this occurs 

automatically in Word when you type a URL and 
hit Enter; the link becomes clickable and a blue 
color and underline appear). 

• Links must be visually distinguishable from the 
surrounding text. 

• Link text must be meaningful and not vague or 
generic. 

Tables 
• Tables must be real tables, and not created in 

some other way (such as using the tab key and 
styling data in a table shape). 

• Tables must not be created using the Draw Table 
option. 

• Tables must have headings. 
• Tables should (ideally) be simple tables. 
• Blank cells should be avoided or marked 

appropriately (such as "No Data"). 

Converting to Tagged PDF 
Saving as Tagged PDF 

To save as tagged PDF from Word in Windows: 
1. Click on File > Save as Adobe PDF. 
2. In the pop-up dialog, click Options. 
3. In the next pop-up dialog, ensure the following 

option is checked: Enable Accessibility and 
Reflow with tagged Adobe PDF. 

4. You should also leave selected the option 
Convert Word Headings to Bookmarks. 

To save as tagged PDF from Word in Mac: 
1. Go to File > Save As. 
2. In the File Format drop-down menu, select 

PDF. 
3. Select the "Best for electronic distribution 

and accessibility" radio button. 
4. Click Export. 

Automated Tagging 

Automated Tagging Without Optimizing the 
Source File: 
Go to Tools > Accessibility > Autotag Document. 
Acrobat will automatically insert tags and produce a 
Recognition Report, including a confidence rating of 
the generated tags and what you must perform 
manually, like adding alt text to images. 

Manual Tags 
Manual tags can be added within the tag tree or 
using the Reading Order Tool. 

Beware Untagged PDF Conversions 
• Scanning a document produces a single image 

with no real, searchable text. 
• Using Print > Save as PDF on a web page or 

within an authoring software program produces 
real text but no tags. 

• Various options within Acrobat produce 
untagged PDFs. Examples include create PDF 
from Scanner, Screenshot, Web Page, and 
Clipboard. 
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Converting to Tagged PDF (continued) 
OCR/Scanned PDFs 
Acrobat Pro DC has a built-in OCR Text Recognition 
tool. Open the file and go to Tools > Create & Edit 
section > Enhance Scans > Recognize Text > In This 
File, and click the Recognize Text button. 

After Converting to Tagged PDF 
Acrobat Pro Is Required 
Adobe Acrobat Pro is required for PDF 
remediation. It isn’t required in order to create a 
tagged PDF, but it is required to fix accessibility 
issues/touch-up. 

The Acrobat Pro Interface 
• The Navigation Pane: Within the Navigation 

Pane are more sub-panes. If you don't see a 
particular pane already displayed, go to: View > 
Show/Hide > Navigation Panes, and select your 
choices. The most relevant ones for accessibility 
are: Content Pane, Order Pane, and Tags Pane. 

• The Document Pane: The Document Pane is the 
main area in which the document is displayed. 
You can select text in this pane in order to tag it, 
or to highlight an object that was previously 
tagged in order to visualize it. 

• The Tasks Pane: In the Tasks Pane, we’re 
interested in the Accessibility section, which 
includes many tools such as the Reading Order 
Tool and the Full Check to identify accessibility 
issues. 

• The text reflow option allows users to magnify 
the text within the constraints of the viewport, 
which minimizes the need to scroll back and 
forth from side to side. 

Tools Used to Review/Assess PDF 
• Popular automated tools include the 

Accessibility Checker within Acrobat and PDF 
Accessibility Checker 2021 (PAC 2021). 

• Manual testing is critical to fully check for 
accessibility. Automated tools have limitations. 

 

• PDF remediation should never be considered 
complete until the document has been 
thoroughly tested using a screen reader. 
Recommended screen readers for testing are 
NVDA and JAWS. 

Document Metadata 
Adding a Document Title 

1. Go to File > Properties. 
2. In the pop-up dialog, go to the Description tab 

and type the title in the Title field. 
3. Next, go to the Initial View tab. 
4. Under the Window Options > Show section, 

select Document Title from the drop-down 
menu. This will ensure that the document title, 
rather than the file name, is displayed. 

Setting the Document Language 
1. Go to File > Properties. 
2. In the pop-up dialog, select the Advanced tab. 
3. In the Reading Options section, select the 

appropriate Language from the drop-down. 

Accessibility Tools 

Basic Procedure to Use PAC 2021 
1. Download and open PAC 2021. 
2. Click the upload button. 
3. Select your file and click Open. The program 

will then run the check. 
4. Examine the generated report and data. 

Acrobat Pro DC Full Check 
• Within Acrobat, go to Tools > Accessibility > Full 

Check. 

Colour Contrast Analyser 
• The Colour Contrast Analyser (CCA) is a free 

tool available for Windows and Mac, to help you 
determine if color contrast meets WCAG 
requirements. You can use the tool by directly 
typing in HEX, RGB, or HSL color values, or you 
can use an eyedropper selector tool by hovering 
over a particular color. 
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Document Metadata (continued) 
Reading Order 
Ensure that reading order is correct and logical. 
Reading order refers to two very different (but 
equally important) things: 
• Screen reader reading order — the order in 

which content will be read out loud by a screen 
reader. It’s 100% managed by the order of tags in 
the Tags Pane and is perhaps the easiest to get 
right. 

• Content reflow reading order —the order in 
which content will be presented once the 
document has been set to Reflow View (aka the 
visual stacking order). It’s 100% managed by the 
order of the content in the Order Pane. This 
reading order is more difficult to get right on 
more complex documents, because moving 
items around in the Order Pane impacts the 
order of tags in the Tags Pane — often 
significantly. 

Tab Order 
When a PDF document has links or form fields, you 
must define the order in which a user tabs through 
them. To do this: 

1. Open the Page Thumbnails Pane. 
2. Select all the thumbnails in the navigation pane 

(Control + click). 
3. Right-click one of the thumbnails and select 

Page Properties. 
4. On the Tab Order tab, ensure this option is 

selected: Use Document Structure (this is the 
default), and click OK. 

Cleanup 

Checking for Unmarked Content 
1. Open the Tags Pane. 
2. Open the Options Menu. 
3. Select Find. 
4. From the drop-down menu, select Unmarked 

Content. 
5. Select the option for Search Document (or 

Search Page if you want to do this page by 
page). 

6. Click Find. 

Delete Empty Tags 
1. Open the Options Menu in the Tags Pane. 
2. Select Delete Empty Tags. 

Manual Tagging and Advanced 
Techniques 
An Overview of Tagging 
You can add tags manually directly in the tag tree or 
using the Reading Order Tool. 

Working with the Tag Tree 

Check for Tags in a Document 
To check if a document is tagged, open the Tags 
pane. You'll either see a tag tree or the words No 
Tags available. 

Add a Tags Root to an Untagged PDF 
1. Open the Options drop-down menu in the 

Tags navigation pane. 
2. Select Create Tags Root. 

Add Empty Tags 
1. Right-click the Tags Root. 
2. Select New Tag. 
3. Select the Type from the drop-down. 
4. Add an optional Title. 
5. Click OK. 
6. This will create an empty tag. You'll need to 

associate content with it. 

Edit Tags/Change Tag Type 
You can do this in two methods: 

1. Double-click the tag and type in the new tag 
directly. 

2. Right-click the tag and select Properties. In the 
Tag tab, select the Type from the drop-down 
menu. 

Move Tags 
To move a tag, simply drag and drop it within the 
tag tree. 

Delete Tags 
You can delete tags by selecting them, then pressing 
the delete key on the keyboard. You can also right-
click a tag and select Delete Tag.  
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Manual Tagging and Advanced 
Techniques (continued) 
Working with the Tag Tree (continued) 

Associate Content with an Existing Tag 
1. Click the Selection Tool. 
2. Select the content in the Document Pane. 
3. Right-click the tag. 
4. Select Create Tag from Selection. 
5. Now a container with the content will be 

created inside that tag. 

Create a Tag and Associate Content 
Simultaneously 

1. Click the Selection tool. 
2. Select the content. 
3. Click the Options menu. 
4. Select Create Tag from Selection. 
5. Select the Type of tag from the drop-down 

menu and click OK. 

Find Tagged Content from the Tag Tree 
To locate content in the document pane from a tag 
in the tag tree, simply click the tag in the tag tree, 
and a bright pink outline will appear around the 
content item in the Document Pane. 

Find Tagged Content from the Document Pane 
1. Click the Selection Tool. 
2. Highlight/select the item with your cursor. 
3. Open the Options Menu in the Tags Pane. 
4. Select Find Tag from Selection. 
5. The tag will be highlighted/selected in the tag 

tree. 

Using the Reading Order Tool 

To open the Reading Order Tool: 
1. Go to Tools > Accessibility. 
2. From the drop-down, select Add Shortcut. 
3. You'll then see it appear as a purple icon in the 

right-side Tools Pane. 
4. If you've previously created this Accessibility 

shortcut, you can just access it directly from the 
Tools Pane. 

5. Select Reading Order. 
 

Container Tags 
Container elements are the highest level of 
element and provide hierarchical grouping for other 
block-level elements. They do not contain semantic 
meaning and are used more for the benefit of the 
document author than the end user. 

These tags are: <Document>, <Part>, <Div>, <Art>, 
<Sect>. 

Artifacts 
If you want screen readers to ignore certain content, 
such as decorative images, you must mark those 
items as Artifacts. Leaving them untagged 
altogether is not the right way to mark content to be 
ignored. 

Paragraphs 
All regular text that is not a heading and that can’t 
be tagged with other tags should be tagged as a 
paragraph. 

Images/Figures 
Images that convey meaning/information should be 
tagged with the Figure tag and given alternate 
text. Decorative images should be marked as 
Artifacts so screen readers can ignore them. 

Headers, Footers, and Page Numbers 
There is no special tag for Document Header or 
Footer. These content items should be tagged as 
either Paragraphs or Artifacts, depending on the 
situation. 
• Tag meaningful information as Paragraphs. 
• Tag redundant information as Artifacts. 

Lists 
Lists are comprised of three or sometimes four tag 
types: 
• List: <L> 
• List Item: <LI> 
• List Body: <Lbody> 
• Label: <Lbl> 
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Manual Tagging and Advanced 
Techniques (continued) 
Links 
An accessible link tag has 2 parts: 
• Link tag: <Link> 
• Link-OBJR annotation: <Link-OBJR> 

Language of Parts 
If your document contains any language changes 
(for example, a sentence or passage in a different 
language than the document language), you must 
specify this. To do this, you’ll use the Object 
Properties dialog in the Tags Pane. 

Tables 
Table tagging includes these tags: 
• Table: <Table> 
• Table row: <TR> 
• Table header cell: <TH> 
• Table data cell: <TD> 

Simple tables have only one header row and/or one 
header column. A complex table has nested levels 
of headers (merged cells). 

References, Footnotes, and Endnotes 
Footnotes and endnotes consist of two linked parts 
— the note reference mark (the small number in 
superscript text) and the corresponding note text. 

To tag notes, you’ll use these tags: 
• <Reference> 
• <Note> 

If you want to create a hyperlink to the note so a 
user can jump to it, you’ll also use these link tags to 
create a link inside the Reference tag: 
• <Link> 
• Link - OBJR Annotation 

 
 
 
 
 
 

Table of Contents 
To tag a table of contents, you’ll use these tags: 
• <TOC> - Table of Contents 
• <TOCI> - Table of Contents Item 
• <Link> and <Link - OBJR> - To create links within 

the TOC that are recognizable to screen readers. 
• <P> - Paragraph, to enclose the link tags 
• <H1> - Heading level 1, for the Table of Contents 

(or Contents) text itself. 

Headings 
Headings are tagged with <H1> through <H6> tags 
(6 levels available, just like in MS Word). There is also 
a general heading tag, <H>. 
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